Fork me on GitHub

[UVa-11525] Permutation 树状数组求kth element+康托展开

题面

传送门: UVa-11525

题目大意:
输出的全部排列字典序大小的第

样例

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
Sample Input
4
3
2 1 0
3
1 0 0
4
2 1 1 0
4
1 2 1 0

Sample Output
3 2 1
2 1 3
3 2 4 1
2 4 3 1

思路

康托展开了解一下

其中a[i]为第位往右边的数里第几大
其实和数位dp一个道理。
具体的栗子(摘自cnblog)

然后是树状数组(Fenwick树)求第k小

这其实是一个反向枚举构造+二分的过程

具体看代码实现吧。

代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
#include<bits/stdc++.h>
#define maxn 50005
using namespace std;
#define lowbit(x) (x&-x)
int c[maxn], K;

void add(int pos)
{
while(pos<=K){
c[pos]++;
pos+=lowbit(pos);
}
}

int query(int pos)
{
int res=0;
while(pos>0){
res+=c[pos];
pos-=lowbit(pos);
}
return res;
}

int BS(int num)
{
int l=0,r=K+1;
while(l<r-1){
int mid=(l+r)/2;
if(mid-query(mid)>=num) r=mid;
else l=mid;
}
return r;
}

int main(int argc, char *argv[])
{
int T;
scanf("%d",&T);
while(T--)
{
scanf("%d",&K);
memset(c,0,sizeof(c));
for(int i=0;i<K;i++)
{
int t;
scanf("%d",&t);
t++;
int k=BS(t);
printf("%d%c",k,(i==K-1)?'\n':' ');
add(k);
}
}
return 0;
}